Description
使用している暗号方式 楕円曲線暗号 X25519 : RFC 7748 Ed25519 : RFC 8032 共通鍵暗号 AES-GCM : https://csrc.nist.rip/groups/ST/toolkit/BCM/documents/proposedmodes/gcm/gcm-spec.pdf ハッシュ関数 SHA2 : FIPS180-2 PBKDF2 : RFC 8018 SHA3 : https://keccak.team/keccak_specs_summary.html
Instructions
⚠ 非常に重い処理が含まれています。 >> https://turbowarp.org/905707628 インターネットなどで暗号通信が行われる様子のシミュレーションを作ってみました。 "https://jinenjo.example.jp" というサイト(実在しません)に自分のIDとパスワードを送るために、安全な接続を確立したいという設定です。 まずサーバーに公開鍵を送ってもらいます。クライアントは、受け取った公開鍵が本物かどうか確認するために、サーバー証明書などの検証を行います。証明書は認証局によって署名されています(EdDSA)。 相手が本物だと確認出来たら、クライアントは自分の公開鍵をサーバーに送り、これによってお互いに秘密の情報を共有します(ECDH)。 最後に共有した秘密の情報と双方の乱数から安全な鍵を生成します。以降の通信内容をこの鍵によって暗号化することで、安全に情報をやり取りすることができます(AES-128)。 攻撃を受けた場合のシミュレーションもあり、時々警告画面が表示されることがあります。 ※ 証明書の検証には非常に時間がかかります。 ※ 実装には省略した部分や不正確な部分があります。 ※ セッションIDがよく分からない ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ⚠SUPER SLOW on Scratch Recommend: >> https://turbowarp.org/905707628 This is a simulator of cryptographic communication on the Internet. It shows what is happening when you access a site "jinenjo.example.jp" (Of course it's just an example) and establish secure connection before you send your userID and password. First, we request server a public key. To ensure the key we received is genuine one, we check a "Server Certificate" signed by trustable third party, "Certificate Authorities". Seond, we generate pair of our secret key and public key, then send a public key to server. By exchanging public key each other, we can generate same secret string from them. Finally, we generate a session key from shared secret and some random number. All contents are encrypted with this key, and safely delivered. It also simulate when you are attacked so it sometimes show warning messages. *It takes very long time verify chain certificate. *There are some inaccuracies or omissions. #math #cryptography #encryption
Project Details
- Visibility
- Visible
- Comments
- Enabled
More Cool Projects
-

Explore Scratch City remix
by Dreamette
-

Beat Up 10 Characters [6]
by LGTheScratchfan2011
-

Scrollable Tape Measure
by TheDogeScratcher
-

MouseHeadz Randomnes all 2
by Luker0707
-

Windows 8.1 Setup Windows 10
by Conla1337_nya
-

One night at flumpty`s 4 (fan-game)
by nilo141
-

(Old)Bfb/Tpot Your Way
by abfdiafan
-

Scratch Day 2025 in □□
by 1296-cat
-

sprunki NO SUS Oren,Pinki. Wenda,Gray remix
by pateopro
-

(1.5 UPDATE) Take care of Acid!
by alexislays
-

ам ням и радио РТИП remix-2
by artemgudz12
-

Talking Tom Cat 2010 remix
by mjbgnjnjfnb
-

Interactive Ice Kitty
by Unicorncat7777
-

Numberblocks Platformer 3 (NUMBERBLOCK 2 EDITION)
by EliGuy_1
-

Mega Black Hole Add Round 24
by chiko1978
-

George The Stickman Collection Menu Art
by ProsteFred
-

Among Us *NEW* IMPOSTER ROLE (mod Stink Monster)
by artur00000
-

Minecraft 3D ONLINE V2
by alexboy456
-

Beat Up Diavolo (Even More New buttons)
by electrobab732
-

Massive Multiplayer Platformer (easy?)
by harekome
-

0-100000
by Tymon2017
-

TNTジャンプを極めし者のTNT発射装置【GIF】【マイクラ実況】
by motonisi777
-

Beat up Edward Premium
by GooleSharty122
-

визер шторм
by sssarrt